Back to overview
Downtime

We are currently interfacing a network issue

May 22 at 04:13pm CEST
Affected services
Game Panel
Direct-Admin Panel
VPS Panel
Game-01
Game-P01
VPS-P01
VPS-B01

Resolved
May 22 at 05:13pm CEST

We have replaced the faulty component, and everything should now be back online.

Created
May 22 at 04:13pm CEST

Some of our services are unavailable