Back to overview
Downtime
Power outage
Jul 19 at 08:55am CEST
Affected services
Game Panel
Direct-Admin Panel
VPS Panel
Game-01
Game-P01
VPS-P01
VPS-B01
Resolved
Jul 19 at 11:07am CEST
We got power again, every is back online!
Affected services
Created
Jul 19 at 08:55am CEST
We are currently experiencing a power outage on our servers. We are in contact with the electricity company to determine the cause and implement a fix.
Affected services